To help new users write (or reuse) their first bots, we have now created a new bot examples repository.

The bots in this repository require the latest version of Xatkit, unless stated explicitly in the bot directory’s README. Installing the Eclipse plugins is not required to execute the bot, but is needed to open/edit their execution models and intent libraries.

Each bot directory contains a .properties file you need to edit to deploy the bot in your own environment. You can read this article to setup DialogFlow and Slack credentials, and additional information is provided in the comments of the .properties file. If you have any issue to run your bot do not hesitate to report is on our issue tracker!

Enjoy! and feel free to contribute your own bots. The more the better!!

Pin It on Pinterest

Share This